GeneWeb7 sur RaspberryPI 3 - GWD NOK

creusois
creusois
Viestit: 107
Sukupuu: Ei-graafinen
Tarkastele heidän sukupuutaan.
Bonjour,

J'ai installé GeneWeb7 sur Raspberri PI OS sur une RPi 3 en suivant cette procédure : https://geneweb.tuxfamily.org/wiki/Installing_GeneWeb_7_on_a_Raspberry_Pi_webserver
Résultat = Tout est OK, ma genealogie MA_BASE se trouve dans /Home/GW/bases7 (tel que suggéré dans la procédure)

:!: Par contre je n'arive pas à lancer GWD et l'utiliser via une interface web.

Lorsque je tente un accès à l'une de mes bases via l'URL spéciale Geneweb c'est OK :
http://localhost/cgi-bin/gwd.sh?b=MA_BASE
https://ip_distante/cgi-bin/gwd.sh?b=combaudon

:!: Et sinon je n'arrive pas à accéder à MA_BASE via GWDSETUP c'est à dire via
http://localhost:2317 (j'accède à la page "ouvrir une généalogie" et lorsque je saisi MA_BASE elle est introuvable)
ou
http://localhost:2316 (j'accède à la page "gestion et création" et lorsque je clique sur "les généalogies existantes, MA_BASE est introuvable)

:idea: J'ai tenté de passer par ce qui est proposé ici https://geneweb.tuxfamily.org/wiki/gwsetup/fr en m'appuyant sur

Koodi: Valitse kaikki

export BIN_DIR="dossier où sont installés les fichiers gwd et gwsetup"
export BASE_DIR="dossier où vous souhaitez conserver vos bases"
cd $BASE_DIR
"$BIN_DIR/gwsetup" -gd "$BIN_DIR" -bindir "$BIN_DIR"
:| ... et j'obtiens l'erreur suivante (voir la dernière ligne) :

Koodi: Valitse kaikki

* Deutsche Version: "de" eingeben
* English version: type "en"
* Version espanola: escribir en el teclado "es"
* Suomalainen versio: kirjoita "fi"
* Version francaise: tapez "fr"
* Versione italiana: digitate "it"
* Latvie�u versija: type "lv"
* Svensk version: skriv "sv"
? fr

Bienvenue dans GeneWeb 7.00-exp

Allez dans votre navigateur Web et ouvrez une des adresses suivantes:
       http://127.0.0.1:2316/
       http://localhost:2316/

Attention: pour que cela fonctionne, vous ne devez pas fermer cette
fenetre!

Si aucune de ces adresses ne fonctionne, il se peut que vous ayez à
configurer dans votre navigateur des options du genre "travailler hors
connexion" ou "ne pas utiliser de proxy pour les adresses locales" ou
"ne pas se connecter sur internet pour l'adresse 'localhost'".

Fatal error: exception Unix.Unix_error(Unix.EADDRINUSE, "bind", "")
Une idée serait la bienvenue :D
------------------------------------------------
Christian Le Creusois
creusois@combaudon.com
@9septembre
------------------------------------------------

Palaa sivulle “GeneWeb”